安装

本文档展示命令,如果是 Windows 请打开 cmd 输入命令执行,如果是类 Unix 系统,请打开任意终端输入命令执行。

安装 Node 和 NPM

详细过程参考官网 https://nodejs.org

Node 版本要求 0.8.x,0.10.x, 0.12.x,4.x,6.x,不在此列表中的版本不予支持。最新版本 node 支持会第一时间跟进,支持后更新支持列表。

安装 FIS3

npm install -g fis3

安装完成后执行 fis3 -v 判断是否安装成功,如果安装成功,则显示类似如下信息:

$ fis3 -v

 [INFO] Currently running fis3 (/Users/Your/Dev/fis3/dev/fis3)

  v3.0.0

   /\\\\\\\\\\\\\\\  /\\\\\\\\\\\     /\\\\\\\\\\\
   \/\\\///////////  \/////\\\///    /\\\/////////\\\
    \/\\\                 \/\\\      \//\\\      \///
     \/\\\\\\\\\\\         \/\\\       \////\\\
      \/\\\///////          \/\\\          \////\\\
       \/\\\                 \/\\\             \////\\\
        \/\\\                 \/\\\      /\\\      \//\\\
         \/\\\              /\\\\\\\\\\\ \///\\\\\\\\\\\/
          \///              \///////////    \///////////

如果提示找不到 fis3 命令并且 npm 安装成功退出,请参考文档 fis#565 解决

升级 FIS3

npm update -g fis3

或重装

npm install -g fis3

文档内容有误,可提 PR,文档地址: /doc/docs/beginning/install.md